XVCapture DICOM Performance Degraded
Incident Report for Apteryx XVWeb
Postmortem

Content/Background

XVWeb DICOM Servers run on multiple server instances in the Azure Cloud. These instances operate in parallel to provide the appropriate scaling required to support customer needs throughout the day. These instances were upgraded on June 23 to support an integration with a future vendors, but some of the instances were not patched as intended. The first time this new integration was enabled for a client today, these un-patched instances began to reject requests from XVCapture and XrayVisionDCV.

Problem Summary

Starting at approximately 12:00 pm EST, the enablement of a new integration within the XVWeb DICOM Server caused some customers using XVCapture or XrayVisionDCV to send images to/from XVWeb may have received one of the following errors:

  • “DICOM Association was rejected.”
  • “A remote image could not be retrieved from a remote server.”

Customers using XVWeb directly to view or import images were not affected by this problem.

Customers using XVWeb Capture Beta to capture images were also not affected by this problem.

Mitigation

At 12:27pm EDT we were able to identify the configuration issue causing the intermittent errors on two of the affected DICOM Server Instances.

At 12:43pm EDT, the misconfiguration was resolved on all instances, and XVCapture and XrayVision DCV returned to normal.

Going forward, we are continuing to evaluate improvements to our process to ensure all DICOM Server instances are patched consistently to prevent situations like this from occurring in the future.

Posted Jun 29, 2023 - 19:27 EDT

Resolved
The problem has been resolved as of 12:35pm EDT.
Posted Jun 29, 2023 - 12:35 EDT
Monitoring
Today at approximately 12:15pm EDT, a subset of the servers responsible for the storage and retrieval of DICOM files became degraded.
Posted Jun 29, 2023 - 12:15 EDT
This incident affected: DICOM (DICOM - Retrieval, DICOM - Storage).